
User’s GuideDataConnect

 DataConnectTM 

Users Guide



TABLE OF CONTENTS
 
 
I. DataConnect Overview .................................................................... 4 
 
II. Getting Started ................................................................................ 4 
 
III. Installing and Upgrading DataConnect ........................................ 4 

A. Installing DataConnect .............................................................. 4 
 
B. Upgrading DataConnect ............................................................ 5 
 
C. Uninstalling DataConnect .......................................................... 6 
 

IV. Configuring DataConnect .............................................................. 6 

A. General Tab ................................................................................. 7 
 
B. Partner Information Tab ............................................................. 8 
 
C. Extract Tab ................................................................................... 8 

1. Using the File Extract Type ..................................................... 9 
 
2. Using the Database Extract Type ..........................................12 

D. Transform Tab ............................................................................ 14 

1. Adding Transformation Rules ................................................ 15 
 
2. Example: Replace Field Rule .................................................. 15 
 
3. Example: Absolute Value ....................................................... 17 
 
4. Example: Substitute Rule ....................................................... 18 
 
5. Example: Delete Row Rule ..................................................... 19 
 
6. Swap Field Rule ...................................................................... 20 
 
7. Date Filter ................................................................................ 21 
 
8. Editing Transformation Rules ................................................ 22 
 
9. Deleting Transformation Rules .............................................. 22 

E. Schedule Tab ............................................................................... 23 

1. Daily Schedule ......................................................................... 23 
 
2. Weekly Schedule ..................................................................... 24 
 
3. Run Now .................................................................................. 24 

F. Alerts Tab .................................................................................... 25 
 
G. Log Tab ........................................................................................26 
 

V. Appendix A – Troubleshooting ...................................................... 27 

A. Error prior to sending data to manufacturer .............................27 
 
B. Error after sending data to manufacturer ..................................28 

VI. Appendix C – Directory Structure ................................................. 28

MODEL N DATACONNECT USER’S GUIDE



LIST OF FIGURES
 
 

Figure 1 Checking for Updates .............................................................. 2

Figure 2 DataConnect Installation ......................................................... 3

Figure 3 DataConnect Configuration .................................................... 4

Figure 4 File Extract ................................................................................ 6

Figure 5 Create a New Field ................................................................... 7

Figure 6 New Field in Possible Fields ................................................... 8

Figure 7 Field Mapping For File Extract ................................................ 9

Figure 8 Field Mapping For Database Extract ..................................... 11

Figure 9 Transform Tab ........................................................................ 11

Figure 10 Replace Field Action: Shipped Rule .................................... 14

Figure 11 Replace Field Action: Return Rule ...................................... 14

Figure 12 Absolute Value Rule ............................................................ 15

Figure 13 Substitute Text Action ......................................................... 16

Figure 14 Delete Row Action ............................................................... 17

Figure 15 Swap Field Rule ................................................................... 18

Figure 16 Populated Transform Tab ................................................... 19

Figure 17 Edit the Transformation Rule .............................................. 19

Figure 18 Confirm Deletion of Rule ..................................................... 20

Figure 19 Schedule Tab: Daily ............................................................. 20

Figure 20 Schedule Tab: Run Now ...................................................... 22

Figure 21 Alerts Tab ............................................................................. 22

Figure 22 Log Tab ................................................................................. 24

MODEL N DATACONNECT USER’S GUIDE



4

I. DataConnect Overview 
DataConnect is self-contained software, installed by you on your hardware and within your firewall, 
which will automate all or part of your sales and inventory reporting. 
 
II. Getting Started 
You need the following prior to installing and running DataConnect:

– System (hardware and software) requirements – see Table 1 DataConnect System Requirements

– Internet connection. This is necessary both for installing/upgrading DataConnect and for sending 
the files to the manufacturer. There may be specific port requirements (for example https port 443) 
depending on the upload requirements of the manufacturer

III. Installing and Upgrading DataConnect 
The following sections describe how to install and upgrade the DataConnect application.

A. Installing DataConnect 
DataConnect can be installed from the Model N website by following these instructions:

1. Go to http://www.modeln.com/channel-data-management/dataconnect/ 

2. Click on the “Download Software” link.

3. Complete the email and send to dataconnect_implementation@modeln.com

4. You will receive a confirmation email and the link to the file.
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Item Recommended

Windows Version Windows 2000, Windows 2003, Windows XP or 
Windows Vista (latest service packs) Note that currently 
Vista is not support for QuickBooks installations.

Disk Space Basic Data connect: 10 MB + data files 
 
QuickBooks driver (only required of DataConnect is ex-
tracting data from a QuickBooks accounting system): 
15 MB

Java 1.6 (if not already installed): 65 MB

Java Version 1.6

Memory 256 MB

Table 1 DataConnect System Requirements
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5. Click on ‘DataConnect for Windows’ link in your confirmation email.

6. DataConnect will start installing on your computer.

a. Your browser will ask you if you want to Run or Save the file. Click “Run”.

b. DataConnect Installer will start running.

c. Select “English” as your “Installer language” (it’s currently the only option)

d. The installer will now look for Java 1.6 on your machine. If it does not exist, you will be prompted 
to install it. DataConnect will only install Java 1.6 for use with DataConnect. If you have a 
previous version of Java on your computer, that pervious version will still be your default.

e. When you see the Install Wizard setup screen, click on “Next >”

f. Read and Accept the license agreement and click on “Next >”

g. Select the default install directory or click on “Browse” to choose a new directory.

h. Click on “Next >” on the Start Menu Folder screen.

i. On the next screen, check the box if DataConnect will be extracting from your QuickBooks system.

j. Installation is complete.

7. To run DataConnect, click on Start/Programs/Model N/DataConnect.

B. Upgrading DataConnect 
Complete the following steps to install upgrades to DataConnect.

1. From the Help menu, select Check for Updates.

2. If an update is available, the Checking for Updates dialog box appears, as shown in Figure 1.

Figure 1 Checking for Updates

3. Click Yes to install updates and following the instructions.

4. DataConnect will tell you the new features of this installation. Click on the Next> button.
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5. DataConnect will complete the installation.

C. Uninstalling DataConnect 
To uninstall DataConnect, click on: 
Start/Programs/Model N/DataConnect/Model N DataConnect Uninstaller

MODEL N DATACONNECT USER’S GUIDE

Figure 2 DataConnect Installation

Note: The uninstaller will remove all the DataConnect software. It will leave any files 
created by DataConnect after the installation, such as data files, log files and property 

files. You can choose to remove these after DataConnect is uninstalled.

IV. Configuring DataConnect 

Configure DataConnect by using the following tabs:

– General – General configuration information.

– Partner Information – Specific to each manufacturer.

– Extract – Set the method for extracting the data and configure the extracted data.

– Transform – Define transformation rules.

– Schedule – Set the schedule.

– Alerts – Define contact information for reporting.
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A. General Tab

Complete the following steps to configure the general settings for DataConnect.

1. On the General Tab enter a description of the configuration in the Description field. This is just a way 
for you to describe the configuration and has no impact on the DataConnect configuration and it’s an 
optional field.

2. Select an Execution Status.

– Disable – When Disable is selected, DataConnect will not run on a schedule, though it will still run 
with the “Run Now” option. Use this mode during the initial configuration or if you ever want to “turn 
off” DataConnect.

– Enable – Use this mode when running DataConnect on schedule.

3. Set the file transfer mode from Select File Transfer Mode drop-down list.

– Write out file only, don’t transfer – Use for testing your configurations. In this mode, DataConnect will 
write the output to your computer but will not send the file to the manufacturer.

– Test Environment –This mode allows DataConnect to upload your data into the manufacturer’s test 
environment.
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Figure 3 DataConnect Configuration

– Log – DataConnect displays run status.

You can change the DataConnect configurations at any time; however, you must specify certain settings 
to get DataConnect up and running.  
 
To save configurations, select File > Save Configuration from the File Menu.
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– Production Environment – Runs DataConnect for normal, production operations. This mode allows 
DataConnect to transmit data through the production path of your manufacturer.

4. The General Tab contains information on the run status of DataConnect

– Last Run shows the start time of the last time DataConnect was run.

– Last Successful Run shows the completion time of the last time DataConnect ran successfully. This 
means that it ran without any data validation, required field or other errors. If DataConnect ran 
successfully, the Last Run and Last Successful Run dates are identical.

– Next Run shows the next time DataConnect is scheduled to run. If DataConnect is scheduled to Run 
Once, this will read “Upon Manual Execution.”

5. To save the General Tab settings, select File > Save Configuration from the File Menu. 

B. Partner Information Tab

The Partner Information Tab allows the user to enter unique partner information. This tab is going 
to be configured based on manufacturer requirements and may be different from manufacturer to 
manufacturer. All fields on this tab are required for successful execution.

C. Extract Tab

Use the settings on the Extract Tab to define the format and the structure of the raw data being pulled 
from your accounting system.

– File – With the File option, you will either manually, or through some process external to DataConnect, 
create a file and place that file into the following directory:

<manufacturer>\reports\new

The file must be named according to the manufacturer for whom you are submitting data and based 
on the name of the manufacturer in the left frame. If the manufacturer’s name is “COMPCO”, then 
the file must be named “COMPCO_dataconnect.txt” in order for DataConnect to recognize and 
process it.

– Excel – This is similar to the File process. The file name must be <Manufacturer Name>_dataconnect.
xls, for example “COMPCO_dataconnext.xls”
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Note: If you have a week where you have no data to report, and if your manufacturer 
requires you to acknowledge that you have no data, you need to put an empty file with 
the proper name in the \new directory. DataConnect will recognize this and make the 

proper report to the manufacturer.

– Database – With the Database option, DataConnect will run a query, configured by you, directly 
against your database or, if you are a QuickBooks user, against QuickBooks.
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The file configuration consists of two steps: configuring the structure of the file and configuring  
the field mapping.

a) Configuring the File Structure

1. From the Select the extract type drop-down menu, select File.

2. From the File Encoding drop-down menu, select one of the following:

– ASCII

– UTF-8

3. From the Text Qualifier field, choose one of the following:

– None

– Double Quote

4. From the Number of Header Rows field, type the number of header rows that appear in the input 
text file. DataConnect ignores these rows during the extraction and transformation processes. For 
example, if there are 2 header rows, DataConnect will not consider the first 2 rows as sales data.

5. In the File Delimiter field, choose one of the following:

– Tab

– Comma

– Pipe

– Other – User defined delimiter
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Figure 4 File Extract

1. Using the File Extract Type
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b) Configuring the Field Mapping

In the Field Mapping area, you configure which fields are in your file, the order of the fields, the data 
type of the fields and, in the case of date fields, the format of the date.

The Fields in the “Possible Fields” window are all the fields available in the data to be reported to your 
manufacturer.

Here’s how to configure the field mapping.

1. In the Possible Fields area, select a field and click the right arrow button to move the Field into the 
Selected Fields area.

2. You can also include fields that are part of your imported file but not part of the manufacturer’s file 
by clicking New Field. The Create a New Field dialog box appears, as shown in Figure 5
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Figure 5 Create a New Field

Note: Fields in red with an asterisk are those fields that the manufacturer requires to be 
populated in the final file. However, it is not necessary that these fields are part of your 

imported file or data. Say that the manufacturer requires your Partner ID. You don’t need 
to have the Partner ID in your imported file as long as the Partner ID is populated in the 

final file through a transform rule.
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You can then select this field and move it to the Selected Fields section by clicking on the 
right arrow.

The Fields in your input file that are not a part of the output file will not be included in the 
file being sent to the manufacturer. However, they may be used to define transform rules 
and need to be mapped for parsing of the input to succeed.

3. Once you have selected all the fields that are on your input file, you need to configure the following:

a. Put the fields in the correct order by highlighting fields in the Selected Fields section and clicking 
on the Up and Down buttons.

b. Select the correct data type. The options are String, Number or Date. Use number for fields that 
should get evaluated as a number, like Quantity. Use Date fields that should get evaluated as a 
date. All other fields should be a String.

c. For Date fields, select the proper date format. There are some predefined date formats you may 
select from, or you may define your own by using the following Characters:

i. M – Month

ii. D – Day

iii. Y – Year

iv. h – hour

v. m – minute

vi. s – second  
 
vii. A – am pm indicator (when time is not specified in 24 hour format)

viii. Separators allowed are /, -, : , comma and space.
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Figure 6 New Field in Possible Fields

After you click OK the field will appear at the bottom of the possible fields
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2. Using the Database Extract Type

The database configuration consists of two steps: configuring the database connection and configuring 
the field mapping.

a) Configuring the Database ConnectionComplete the following steps to configure 
DataConnect to extract Database file data.

1. From the Select the extract type drop-down menu, select Database.

2. From the Database Type drop-down menu select either SQL Server or JDBC-ODBC. DataConnect 
contains a driver that will natively connect to a SQL Server database. Otherwise, it can connect to any 
ODBC compliant database. 

Note: QuickBooks users should select the JDBC-ODBC option 

3. In the Database Server field, type the database server. If Database Type selected is SQL Server, enter 
the name of the SQL Server. If Database Type selected is JDBC-ODBC, enter the ODBC Data Source 
Name. In case of QuickBooks, enter the ODBC Data Source Name for QuickBooks.

4. In the Database Port field, type the database port. This is not needed for JDBC-ODBC

5. In the Database Name field, type the database name. This is not needed for JDBC-ODBC option.
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Figure 7 Field Mapping For File Extract
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6. In the Database User ID field, type the database user ID. This is optional for a JDBC-ODBC 
configuration.

7. In the Database User Password field, type the database server’s password. This is optional for a 
JDBC-ODBC configuration.

8. In the Confirm Password field, re-type the password.

9. In the Enter SQL field, type a SQL statement that pulls all of the necessary data from your accounting 
system.

10. To save the Extract Tab settings, select File > Save Configuration from the File Menu 

 
Note: You can test your database connection by clicking on Test Connection. You can test your SQL 
statement by clicking on Test SQL.

b) Configuring the Field Mapping

The process for configuring the field mapping for the Database Extract is identical to configuring the 
mapping for File Extract. The order in which you pull fields in your SQL statement is the order as they 
need to be configured in the field mapping. It is not necessary for the field names to match the names 
of the fields on the extract Tab. For example, a SQL statement that looks like this:

Select

customer_name,

customer_street,

customer_city,

customer_state,

customer_zip,

customer_phone,

custom_field,

quantity_shipped,

date,

invoice_num

From

Mytable
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D. Transform Tab

Use the Transform Tab to add, edit and delete transformation rules.

might have an extract configuration that looks like this:

Note: The user must complete the settings in the Extract Tab section prior to defining 
transformation rules.

Figure 8 Field Mapping For Database Extract

Figure 9 Transform Tab
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The Transform Tab shows the configured rules.

– The order defines the order in which the rules will get executed. In the above example, the rule 
“Remove non manufacturer items” will get executed prior to the rule “Clean up Part Number”. You can 
change the order of the rules by highlighting the rule and clicking on the “Up” and “Down” buttons. All 
Rules are executed against a single data row prior to moving to the next data row.

– The name is the name of the rule and should be unique.

– The Enabled column shows whether the rule is enabled or not. This feature lets you create a rule 
and disable it without deleting it.

– The Valid column will indicate green if it appears the rule was configured properly and red if it 
appears the rule was configured improperly.

– Click on “New…” to create a new rule.

– Highlight a rule and click on “Edit…” (or double click ) to edit a rule.

– Highlight a rule and click on “Delete…” to delete a rule.

1. Adding Transformation Rules

Complete the following steps to create a Transformation Rule:

– Enter a Rule Name for the Transformation Rule. Use a name that will tell you what

the rule does when looking at the transformation tab.

– Define the Condition(s) for the Transformation Rule. Click on the “Add” button to start a condition. 
The condition describes the circumstances under which the action(s) should be run. A single rule 
can have up to 5 conditions. In order for a rule to be triggered, all conditions must be met. There 
are three types of conditions:

• if - The action is only be executed if the condition is met.

•  ifNot - The action is only be executed if the condition is not met.

•  Always - The action is always be executed.

– Define the Action(s) for the Transformation Rule. Click on the “Add” button to start an action. The 
action describes the transformation that DataConnect will take on your data. A single rule can have 
up to 5 actions. If a rule is triggered, all actions will be executed in the order they are defined.

2. Example: Replace Field Rule

The Replace Field Action allows you to set a field to a specific value based on a condition. To create a 
Replace rule, follow these steps:

1. Click New. The Create the Transformational Rule pop-up window displays.

2. Type the name of the Transformational Rule in the Rule Name field.

3. Define the Transformation Rule parameters in the Condition area:

a. Click on “Add” next to “Conditions:”

b. Select one of the following conditions from the Condition drop-down list.

c. For If and If Not conditions, select a match case from the dropdown list:
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• Contains – The condition is met if the field contains the string entered.

• Date Filter - This is a special case that is described in another example.

• Ends With – The condition is met if the field ends with the string entered.

• Starts With– The condition is met if the field begins with the string entered.

• Equals – The condition is met if the value in the chosen field has the same value as you type in. This 
can be used for both string and numeric comparisons.

• Matches – Works the same as equals but allows for the use of regular expressions.

• Greater Than – The condition is met if the value in the data is greater than the value entered in the 
rule.

• Less Than – The condition is met if the value in the data is less than the value entered in the rule 

Note: When matching on text, DataConnect is case insensitive. 

d. For If and If Not conditions, select a field from the field dropdown list. All fields that are sent to 
the manufacturer will be included in the drop-down list as well as any custom fields that were 
mapped on the Extract Tab.

e. Type the matching text for which the Transformation Rule applies in the text field.

4. Set the parameters of the Transformation Rule’s Action:

a. Click on “Add” next to “Actions:”

b. From the Action drop-down list select Replace Field

c. Select a field from the field drop-down list. All fields that are sent to the manufacturer will be 
included in the drop-down list as well as any custom fields that were mapped on the Extract 
Tab.

d. Type a corresponding text string in the With field.

5. If you want the rule to be applied in its current state, check the Enable Rule check box In the upper 
right hand corner.

6. Click Save. The Create the Transformation Rule dialog box closes.

7. To save all of the Transformation Rule Tab settings, select File > Save Configuration from the File 
Menu.

For example, your Manufacturer requires that the Quantity Qualifier field is set to “76” for returns and 
“39” for shipments. Let’s say that in your system, sales are represented by positive quantities and 
returns are represented by negative quantities. This can be accomplished by setting up two rules. First, 
set up the “Shipped” rule like this:
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This rule says that if the QUANTITY is greater than 0, set the QUANTITY_QUALIFIER to 39.

Next, create a “Return” rule like this:

3. Example: Absolute Value

The Absolute Value rule should only be applied to numeric data. A typical example would be if you 
use negative quantities to report returns but your manufacturer only wants you to submit positive 
quantities. To build this rule you would follow these steps:

1. Click New. The Create the Transformational Rule pop-up window displays.

2. Type the name of the Transformational Rule in the Rule Name field.

3. Define the Transformation Rule parameters in the Condition area. See the Replace Field section 
for details on setting up the condition.

4. Set the parameters for the Transformation Rule’s Action:

a. From the Action drop down list select Absolute Value
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Figure 10 Replace Field Action: Shipped Rule

Figure 11 Replace Field Action: Return Rule



18

b. Select the field for which you want to take the absolute value.

For example, say your system stores returns as a negative quantity but you need to report a positive 
quantity to your manufacturer. This can be accomplished by setting up a rule like this:

4. Example: Substitute Rule

The Substitute rule allows you to set a text string to another text string based on a condition. To create 
a Substitute Text rule, follow these steps: Click New. The Create the Transformational Rule pop-up 
window displays.

5. Type the name of the Transformational Rule in the Rule Name field.

6. Define the Transformation Rule parameters in the Condition area. See the Replace Field section for 
details on setting up the condition.

7. Set the parameters of the Transformation Rule’s Action:

a. From the Action drop-down list select Substitute

b. Enter the text string that will get substituted

c. Enter the text string that the value in “b” above will get substituted with.

d. Select the field in which the text string on which the rule will act.

8. If you want the rule to be applied in its current state, check the Enable Rule check box in the upper 
right hand corner.

9. Click Save. The Create the Transformation Rule dialog box closes.

10. To save all of the Transformation Rule Tab settings, select File > Save Configuration from the File 
Menu.

For example, say for bookkeeping purposes you put a “-BD” at the end of some part numbers in the 
PART_NUMBER field to indicate that the sale is associated with a big deal. However, the “-BD” is not 
a valid part number and thus needs to be removed. This can be accomplished by setting up a rule like 
this:
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Figure 12 Absolute Value Rule
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This rule says that if the PART_NUMBER ends with “-BD” then substitute “-BD” with <null> (thus 
removing “-BD” in the PART_NUMBER field. When substituting text, DataConnect is case sensitive.

5. Example: Delete Row Rule

The Delete Row rule allows you to remove an entire row from the extracted file based on a condition. 
To create a Remove Row rule, follow these steps:

1. Click New. The Create the Transformational Rule pop-up window displays.

2. Type the name of the Transformational Rule in the Rule Name field.

3. Define the Transformation Rule parameters in the Condition area. See the Replace Field section for 
details on setting up the condition.

4. Set the action to Delete Row. No further action instructions are required.

5. If you want the rule to be applied in its current state, check the Enable Rule check box In the upper 
right hand corner.

6. Click Save. The Create the Transformation Rule dialog box closes.

7. To save all of the Transformation Rule Tab settings, select File > Save Configuration from the File 
Menu.

For example, you have created a custom field called VOIDED. The database lists all voided order 
numbers by ending with a value of “Y”, which indicates that the order has been voided. These records 
need to be removed from the file.
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Figure 13 Substitute Text Action
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This rule says that the row should be removed if the Voided field equals “Y” (or “y” since comparisons 
are not case sensitive).

6. Swap Field Rule

The Swap Field Rule allows you to swap the contents of one field with the contents of another field 
based on a condition. To create a Remove Row rule, follow these steps:

1. Click New. The Create the Transformational Rule pop-up window displays.

2. Type the name of the Transformational Rule in the Rule Name field.

3. Define the Transformation Rule parameters in the Condition area. See the Replace Field section for 
details on setting up the condition.

4. Set the action to Swap Field and select the two fields to swap.

5. If you want the rule to be applied in its current state, check the Enable Rule check box In the upper 
right hand corner.

6. Click Save. The Create the Transformation Rule dialog box closes.

7. To save all of the Transformation Rule Tab settings, select File > Save Configuration from the File 
Menu.

For example, you want to swap address 1 and address 2 in cases where address 1 is null and address to 
is not null.
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Figure 14 Delete Row Action
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7. Date Filter

DataConnect will only include invoices that are from the last successful run until the current run time. 
DataConnect uses the Date Field that you set as the Date Filter to determine which invoices should be 
included in the report. Invoices that fall outside of this date range will be removed from the report.

1. Click New. The Create the Transformation Rule pop-up window displays

2. Type in the name of the Transformation Rule in the Rule Name field. 

Note: The field must be a date field. DataConnect will not validate that you selected a date field until it is 
run against a data set, at which time the process will fail and the error will be logged. 

3. Define the Transformation Rule parameters as in the below screenshot. This filter should 
be defined exactly as described below, though you need to select the Date Field on which 
DataConnect should apply the filter. In the below example, INVOICE_DATE was selected, but you 
can select whatever date is most appropriate.

4. If you want the rule to be applied in its current state, check the Enable Rule check box in the upper 
right hand corner.

5. Click Save. The Create the Transformation Rule dialog box closes.

6. To save all of the Transformation Rule Tab settings, select File > Save Configuration from the File 
Menu.
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Figure 15 Swap Field Rule
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8. Editing Transformation Rules

To edit a Transformation rule complete the following steps:

1. Select the rule in the Transformation Rule area of the Transformation Tab.

2. Click Edit. The Edit the Transformation Rule pop-up window appears

3. Complete the desired changes.

4. Click Save. The Edit the Transformation pop-up window closes.

5. To save all of the Transformation Rule settings, select File > Save Configuration from the File 
Menu.

9. Deleting Transformation Rules To delete a Transformation rule complete the following steps:

1. Select the rule in the Transformation Rule area of the Transformation Tab.

2. Click Delete. The Confirm Deletion of Rule pop-up window appears.
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Figure 16 Populated Transform Tab

Figure 17 Edit the Transformation Rule
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3. Click Yes.

4. To save the Transformation Tab settings, select File > Save Configuration from the File Menu.

E. Schedule Tab

The Schedule Tab allows the user to set the frequency of the DataConnect application’s execution.

– Daily – DataConnect runs daily at the specified time.

– Weekly – DataConnect runs weekly at the specified day and time.

– Run Now – Allows the user to manually run DataConnect. This option is good for testing the 
configurations.

1. Daily Schedule

MODEL N DATACONNECT USER’S GUIDE

Figure 18 Confirm Deletion of Rule

Figure 19 Schedule Tab: Daily
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Complete the following steps to set DataConnect to run on a daily schedule.

1. Select Daily in the Frequency of Execution area.In the Set the Run Time area, set the time for 
DataConnect to run. 

Note: The run time is based on a twenty-four hour clock: 1:00 represents 1:00 AM and 13:00 represents 
1:00 PM 

2. In the Run Status area, confirm the Next Run date and times.

3. To save the Schedule Tab settings, select File > Save Configuration from the File Menu.

2. Weekly Schedule

Complete the following steps to set DataConnect to run on a weekly schedule.

1. Select Weekly in the Frequency of Execution area.

2. In the Set the Run Time area, set the day of the week and the time for DataConnect to run.

3. In the Run Status area, confirm the Next Run date and times.

4. To save the Schedule Tab settings, select File > Save Configuration from the File Menu. 

Note: When configuring DataConnect to run on a schedule or if the schedule is changed, along with 
saving the configuration, the Dataconnect service should also be restarted. 

3. Run Now

Run Now allows the user to manually run DataConnect. This is particularly useful in testing the 
configurations. Complete the following steps to run DataConnect once.

1. Select Run Now in the Frequency of Execution area.

2. If a Date Filter Rule is defined, enter the start date in the Extract from date field. This is the date 
from when the date filter will be applied. In the below example, all records with an Invoice Date 
prior to 08/01/07 or records greater than or equal to the current date will be deleted.

3. To save the Schedule Tab settings, select File > Save Configuration from the File Menu.
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F. Alerts Tab
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Figure 20 Schedule Tab: Run Now

Figure 21 Alerts Tab
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Complete the following steps to set email alerts. Alerts are sent up on each run of DataConnect. The 
email will let you now whether or not DataConnect ran successfully. The email contains detailed log 
information to help troubleshooting if there are any issues.

1. In the Email Server field, type the name or i.p. address of your email server.

2. The Email Server Port field is set to 25 by default. You can change the port if your server is 
configured differently.

3. In the Alert Email Address field, type the email address that will receive the alerts. Multiple emails 
can be entered if separated by commas.

4. In the Alert From Email Address field, type the email address of the user from whom the alert 
emails originate.

5. In the Email Server User ID field, type the user name of the user who will log into the mail server 
to send the emails. This is not required for all email servers.

6. In the Email Server Password field, type the password for the user who will log into the mail 
server to send the emails. This is not required for all email servers.

7. In the Confirm Password field, retype the password. This is not required for all email servers.

8. From the Email Server Encryption drop-down list, select (this is not required for all email servers.): 
 
None 
SSL 
TSL

9. To save the Alert Tab settings, select File > Save Configuration from the File Menu. 

Note: If you click on Send Test Email, DataConnect will send an email with the subject line 
“DataConnect Test Email” to the configured account 

G. Log Tab

The Log Tab displays log information for each run of DataConnect. This information is updated every 
thirty seconds.
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The actual log file are stored in the DataConnect directory structure: DataConnect/<manufacturer>/logs. 
The log file is named dataconnecthistory. log.

V. Appendix A – Troubleshooting

There are two basic error scenarios.

A. Error prior to sending data to manufacturer

In this scenario, DataConnect runs but you get an email with the subject line that contains “Dataconnect 
Failure”. This can be due to various reasons. For example, you may have indicated in the Extract 
configuration that the input data has 10 fields, but the actual data has 11 fields. To resolve:

1. Look at the log information and identify the error. If it’s a data validation error, correct the data at 
the extract point.

2. Re-run DataConnect. You may need to run it manually (“run once”).

3. If you do run it manually, don’t forget to set DataConnect back to your normal schedule. 
Remember, anytime you make a change, you must save the configuration before the change will 
take affect.

In this scenario you must re-run DataConnect with the correct data. If you correct and send the data 
outside of DataConnect, the system will not know that data was successfully processed and to reset the 
last successful run date. This could lead to re-reporting invoices the following week.
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B. Error after sending data to manufacturer

In this scenario, DataConnect runs and uploads data to the manufacturer, but you get an email from the 
manufacturer identifying an error and a request to resend. To resolve:

1. Find the file that was sent in the /reports/transformed directory.

2. Make the corrections directly in this file.

3. Manually upload the file to the manufacturer.

It is very important in this scenario that you correct the data outside of DataConnect. The reason is that 
from DataConnect’s perspective, the run was successful and the last successful run date is reset.

 
 
Note: If you are unable to resolve an issue or have difficulty reading the log file, please contact 
dataconnect@Modeln.com. 
 

VI. Appendix C – Directory Structure

This section describes where files are placed in the DataConnect directory structure

– <manufacturer>/reports/new – This is where you place the file to be read by DataConnect if you 
choose the “File Extract” option. Note: The file name must be

<manufacturer>_dataconnect.txt.

– <manufacturer>/reports/archive – This is where DataConnect puts the original file or database 
extract prior to transformations. A timestamp will be appended onto the file name.

– <manufacturer>/reports/transformed – This is where DataConnect puts the transformed file. This 
is the file that is in the manufacturer format. Transformed files can have one of 3 extensions. In all 
these cases, DataConnect successfully created the file. The extension will still be .csv but the file 
will have one of the below in the file name.

o “notSent” – DataConnect was configured to not send the file to the manufacturer.

o “success” – The file was successfully sent to the manufacturer.

•  “failed” – The file was not successfully sent to the manufacturer.
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